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Change History
Document Version

Changes

1.7

Updates to reflect changes introduced in ICE Risk Model Software version
1.3.0.6:
WFPRCAP - This version the option to cap the Weighted Futures Price Risk
(WFPR) for a given ICE Risk Model Combined Contract within an intercontract spread to be the minimum value of the scanning ranges applicable
to any contract within that ICE Risk Model Combined Contract. This is
controlled via a menu option that can be enabled/disabled by the user (See
5.6.7). The WFPR capped value is now reflected also in the Intercontract
Spread report which now reports both the uncapped and capped WFPR
values (ICS Report)
Output of Positions resulting from Position Allocation – A new menu
option allows user to request that the positions created as a result of the
Position Allocation process be written out to an output file; this is intended to
assist in understanding the allocation process and to support users
developing their own software.
Value Losses Data File – A new VL.CSV data file can be generated (VL
Report). This is a data file providing a breakdown of value losses for each
contract position; this is intended as an aide to analysing scanning losses.
This contains the same information as the SVL report in a data format.
Enhanced support for NYSE Liffe margining
Method 02 Inter-Contract Spread – This version implements fixes to the
computation of Method 02 Inter-Contract spread credits. Method 02
spreads are utilised for certain Liffe products and this now means that ICE
Risk Model fully supports calculation of Liffe contract margin.
Results Data File – The Results Data file (Results.csv) generated by ICE
Risk Model now includes the Exchange Id in order to better support margins
calculated for Liffe portfolios with 3 exchanges – “L”, “O” and “X”.
NOTE that ICE Risk Model allows multiple Array files to be loaded at the
same time allowing margin to be calculated across portfolios spanning
multiple exchanges at the same time.

1.8

Apply changes to embedded URLs in order to link to updated ICE web site.

1.9

Updated the document to reflect the ICE’s rebranding of our risk
management offerings to ICE Risk Model (IRM). The current implementation
is not changing; this is merely a rebranding of ICE’s risk management
offerings.
Removed references to SP5 which has been previously deprecated.
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1

Introduction

ICE Risk Model is a scenario-based, parameterized risk model used to evaluate the risk exposure to the
clearinghouse in the event of a defaulting portfolio.
All market participants and users, as well as others with an interest in understanding how ICE Clear
margins its products, are welcome to download and use the ICE Risk Model software.
Users are required to accept the terms of the license as part of the installation process. Users are not
charged for use or download of the software, but there are limitations to using the software in commercial
applications.
ICE Risk Model utilises the Microsoft .NET Framework, version 3.5. Users must install this software prior to
installing ICE Risk Model.
TECHNICAL REQUIREMENTS:
Windows Server 2003; Windows Server 2008; Windows Vista; Windows XP, Windows 7 (32bit and
64bit)
Microsoft .NET Framework version 3.5
400 MHz Pentium processor or equivalent (minimum); 1GHz Pentium processor or equivalent
(recommended)
96 MB Memory (minimum); 256 MB Memory (recommended)
Up to 500 MB of available hard disk space may be required (including .NET)
800 x 600, 256 colours Display (minimum); 1024 x 768 high colour, 32-bit Display (recommended)
If you have any questions relating to the ICE Risk Model, contact:
ICUS ICE Clear U.S. Operations team at iceclearus@theice.com or +1 212 748 4001
ICEU ICE Clear Europe Operations team at iceuops@theice.com or +44(0)20 7065 7600
ICCA ICE Clear Canada Operations team at ICEClearCanadaOperations@theice.com
ICSG ICE Clear Singapore Operations team at ICEClearSingaporeOperations@theice.com
ICNL ICE Clear Netherlands Operations team at add ICEClearNetherlandsOperations@theice.com + 31
20 3055164

1.1

ICE Risk Model for OTC FX

Note that the majority of this document applies equally to the calculation of margin for cleared energy
contracts and cleared OTC FX contracts. Where different approaches are applicable, these are highlighted.
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2

Installation Process

ICE Risk Model can be downloaded from the Risk management section of the ICE website:
https://www.theice.com/clear-europe/risk-management

3

ICE Risk Model Parameter File(s)

In order to use ICE Risk Model to calculate initial margins, the user is required to input two files into ICE
Risk Model tool, the first of which is the risk parameter file (also referred to as the IRM Array file). The ICE
Risk Model parameter files are available under the risk management section of the respective jurisdiction.
For example, ICE Clear Europe ICE Risk Model parameter files are available under:
ICE Energy & Liffe Products: https://www.theice.com/clear-europe/risk-management
Files can be downloaded from the web site via any web browser. Additionally, this web page is stored as a
favourite within ICE Risk Model Tool and can be accessed from within the tool by selecting “Favourites” →
“Download Risk Parameters from ICE” and the web page will appear within the tool window.
ICE Risk Model parameter files are available for each business day for download.
For Energy & LIFFE, files are available in a fixed record format (SP6) and in CSV format (CSV). The CSV
format file is smaller in size and it is recommended that this format be used.
When calculating margin requirements posted by ICE Clear on the morning of the current business day the
ICE Risk Model file from the previous business day should be used. Files from historic dates are also
available.
NOTE: Save the parameter file to an easily accessible place on your PC. For use by ICE Risk Model, it is
recommended that you save the file to “My Documents\ICE Risk Model\data” as this is the default location
that the program will look for the parameter file(s).
NOTE: When calculating margin for NYSE Liffe portfolios you may need more than one ICE Risk Model
Array file. For example, if your portfolio contains both FTSE Futures and FTSE Options you will need both
the “LIF” and “OPT” array files.
Further information about the different formats of ICE Risk Model Parameter files (IRM Array files) and the
various alternatives for obtaining them (including ICE MFT) can be found in the following documents:
ICE Risk Model Array File Formats
https://community.theice.com/docs/DOC-1100
ECS, Reporting and MFT Technical User Guide
https://community.theice.com/community/ice_clear/user-guides
Both documents are published on the ICE Community site.

4

Position File

The second file ICE Risk Model requires as an input, is the position file. This file needs to be produced by
the user and uploaded into ICE Risk Model in either a CSV file or a fixed-format text file. CSV files are
preferred as they may be easily edited using programs such as Microsoft Excel.
The following information, by column, is required in the position file:
A. Position/Trade Flag - this is always P.
B. Account Name/Identifier - The name of the account (portfolio identifier), this can take any
value, such as the user's company name. The file may contain positions for multiple Account
Names; a separate margin figure is calculated for each account.
C. Exchange Code – “I” for ICE Energy; “L” for Liffe Financials; “O” for Liffe Equity Options, “X”
for Liffe Commodities; “F” for FX.
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D. Exchange Contract Code - this is the physical commodity code of the contract.
A full list of the ICE Energy physical commodity codes is available from the following address:
https://www.theice.com/products/All-Product-Codes.
There is a separate set of commodity codes for OTC FX. These are available from the OTC
FX product guide.
E. Contract Type - this field can take one of the following values: “F” for futures, “C” for call
options, “P” for put options, “M” for monthly contracts and “D” for daily contracts, and for OTC
FX “N” for NDFs.
F. Expiry Date YYYYMMDD - this is the delivery date required. A year and month is sufficient for
futures, for example 20090900 for September 2009 future. Daily contracts require the DD
field to be completed as appropriate. For OTC FX this is the final maturity date of the NDF
contract.
G. Strike Price - For futures/NDFs, enter “0” in this field, or leave it blank. For options the strike
price in ticks is required. For example, for a $75.50 Brent option a value of “7350” should be
entered, for Gas Oil options “65000” represents a strike price of $650 and for ECF options
“1200” represents a strike price of EUR 12.00.
Please note that net liquidation value of options is not included in the calculation of initial
margins.
H. Net Position- the net number of lots the account is long or short within an individual contract
at expiry date level, a negative sign is required for short positions. Positions for options should
be netted at strike price level. ICE Clear calculates all margin requirements based on net
positions and NOT gross positions.
For OTC FX this is the terms notional amount on an NDF trade. Positive implies you are
buying the terms currency, negative implies you are selling the terms currency. You can enter
positions as trades or as net amount by value date for each currency pair (commodity code).
I.

Regime and Customer Type – OPTIONAL. The combination of Regime and Customer Type
(if specified) is used to determine the amount of additional margin that is added to the
computed initial margin depending upon the type of customer. If no Regime/Customer type is
specified for a position, no additional margin is added.
Regime
DCO or RCH (FCMs should specify DCO)
Customer Type
H – Hedger. Use Rate applicable to Hedgers
S – Speculator. Use rate applicable to Speculators
M – Member. Use rate applicable to Members

Example
Below is an example of a position file created in Excel:
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The position file shown represents a 1 lot long position for September 2009 Brent futures and a 1 lot long
call position in September 2009 ECX EUA options at a strike price of EUR 12.00.
If you use Excel to create the positions, you MUST save the data as a CSV file:
Click “File” → “Save As...”, then drop down the “Save As Type” box and select “CSV (Comma
delimited)”. Click “Save”.
If you create the position file using some other means (e.g. write the positions into a file from your own
software), you must write the values as comma-separated values. The position file shown in the example
above would look like the following, if you opened the file in Notepad (for example):
P,ICE,I,B,F,20090900,0,1
P,ICE,I,C,C,20090900,1200,1
4.1

Example Position File for OTC FX

Below is a sample OTC FX positions file created in Excel:

As can be seen, column B contains two different customer/portfolio names; column D contains the codes
for the currency pairs
UK
- USDKRW
UD
- USDIDR
UL
- USDCLP
UD
- USDIDR
Column F contains the maturity date (a.k.a. the value date) and lastly column H contains the net terms
currency amount. For example, in row 1 the positive terms amount indicates the position is long terms
currency. You can use any sign convention for the terms amount that you like; all that matters is that you
use a consistent convention within a position file.
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5

Using ICE Risk Model

5.1

Download ICE Risk Model Parameter File

The first step, if you have not already done so, is to download the ICE Risk Model Parameter file. This can
be carried out from within ICE Risk Model by selecting “Favourites” → “Download ICE Clear Europe Risk
Arrays” and the download web page will appear within the ICE Risk Model browser window. Note: There
are multiple menu items to select Array files for each Jurisdiction.
Select the ICE Risk Model parameter file you require and save it locally on your PC; it is recommended that
you save it to “My Documents\ICE Risk Model\data”.
See section 3 for further information about ICE Risk Model Parameter files.
5.2

Load Risk Parameters (ICE Risk Model Arrays)

The next step, is to load the ICE Risk Model parameter file(s) (IRM Array files) into the application.
To load the parameter file into the application, either:
Select “File” (on the application menu) → “Load Risk Parameters” or
Click

, then “Load Risk Parameters”.

Navigate to the ICE Risk Model parameter file (IRM Array file) and select it.
ICE Risk Model will now load the ICE Risk Model Arrays
Repeat this step for additional ICE Risk Model Arrays as required
NOTE that you can load multiple ICE Risk Model Array files. For example when calculating margin for a
NYSE Liffe portfolio you might need to load the “LIF”, “FOX” and “OPT” array files in order to compute
margin across a portfolio that comprises financials, FTSE Futures, FTSE Options, Equity Options and
Commodity positions.
5.3

Load Position Files

In a similar manner, upload the position file:
Select “File” (on the application menu) → “Load Positions” or
Click

, then “Load Positions”.

Navigate to your position file and select it.
ICE Risk Model will now load your positions
Repeat this step to load further position files
5.4

Calculate Margin

Once you have loaded ICE Risk Model Array(s) and position(s) into ICE Risk Model, it has all the required
information needed to calculate the initial margin requirement.
At this point you MUST select the proper setting for the WFPR Cap option. The WFPR Cap option is
accessed through the Tools menu: Tools→ Apply WFPR Cap.
For margining of ICE Energy contracts, this option should be enabled; it should be ticked (see
below)
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For margining of NYSE Liffe contracts, this option should be disabled; it should not be ticked (see
below)

Now run the margin calculation by either:
Clicking “Margin” (on the application menu) → “Calculate” or
Clicking the,

, icon.

If your position file contains positions in contracts for which no ICE Risk Model array is found, then, these
positions will be excluded from the margin calculation and warnings will be written to the log file (See
section 5.6.2).
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5.5

Viewing Reports

Once ICE Risk Model has calculated the margin requirement, the user can select which reports to
generate. You can select your chosen reports, by ticking those you require, and generate only those
reports by selecting “Margin”→ “Report Generation” → “Generate Selected Reports” (or clicking ).
Alternatively, selecting “Margin”→ “Report Generation” → “Generate All” will cause ICE Risk Model to
generate all reports.
The user is now able to view the reports generated by selecting “View”→ “Reports” → and selecting the
report you wish to view, or by clicking

.

Report options include:
•

Summary By Margin Group

•

Summary by Combined Contract

•

Summary by Scanning Risk

•

Summary Value Losses

•

Series Value Losses

•

Combined Contract Tier Details

•

Strategy Spread Charge Details

•

Intermonth Spread Charge Details

•

Prompt Date Charge Details

•

Intercontract Spread Credit Details

•

Expiry Group Delta Details

Each report will show a breakdown of how a particular charge or credit is calculated. See Appendix 1 for
details on each report.
For OTC FX, the following reports will be blank, as the ICE Risk Model set up for these products does not
include Strategy Spreads, Prompt Date charges etc.

5.6

•

Strategy Spread Charge Details

•

Prompt Date Charge Details

•

Expiry Group Delta Details
Other Options and Functions

Various options are accessed under the Tools menu.
5.6.1 Nearest Strike Option
Under normal circumstances, any position for which no ICE Risk Model array is found will be ignored during
the margin calculation process and will generate a warning in the log file.
However, this behaviour can be modified in the case of options contracts. If your position file contains
options positions which have options positions with strike prices for which no ICE Risk Model array is found
within the ICE Risk Model parameter file, then, ICE Risk Model provides the facility, called “Use nearest
Strike”, which causes those positions to be processed using the array for that strike price closest to that of
the position. This option is only recommended for intra-day what-if type analysis as it will only give an
approximation that may not be comparable to the real margin called by the Clearing House at end of day.
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Entries will be written to the Log file to record the substitute arrays that were applied. It is the user’s
responsibility to judge whether this yields an appropriate approximation.
Note that this is not applicable for OTC FX.
5.6.2 Viewing Log File
Any errors or warnings issued during any part of the process are output to a log file. This log file may be
viewed by selecting “View” → “Log File” on the application menu.
5.6.3 Changing results File Name
You can change the default name of the results file generated by ICE Risk Model by selecting “Tools” →
“Results File” and typing a new name in the file name box (default name Results).
5.6.4 Changing Warning Threshold
By default, the processing of margins will stop after 200 warnings have been generated.
You can change this threshold by selecting “Tools” → “Warning Threshold” and entering a different value in
the box (default value 200).
5.6.5 Delta Split Allocation
Position allocation is the process whereby the portfolios provided in the position file (See 4) are transformed
according to the Position Allocation records within the ICE Risk Model Array file. By default, ICE Risk
Model carries out this process. This can be disabled (not recommended) by disabling this option.
5.6.6 Output Allocated Positions
To assist in better understanding the Position Allocation process (referred to above), the positions that are
created as a result of the transformation process can optionally be written to an output data file. By default,
this file is written to the ICE Risk Model data directory and is named ppf.csv in “My Documents\ICE Risk
Model\data”.
5.6.7 Apply WFPR Cap
ICE Risk Model can constrain the amount of the WFPR used to calculate ICE Risk Model Inter-Contract
Credits (Method 10). Whether this capping is applied can be enabled/disabled through this option.
In order to reflect Clearing House margin, this should be ENABLED for ICE Energy contracts and
DISABLED for NYSE Liffe contracts.

6

Using ICE Risk Model in Batch Mode

An alternative way to calculate margins is by using the command line version of ICE Risk Model, a program
called “Marbat” which can be found in the same program directory as ICE Risk Model; by default, this is
“C:\Program Files\ICE Clear\ICE Risk Model”.
Running this program with no command line arguments causes it to output its ‘usage’; a list of all command
line parameters and options.
The Marbat command line syntax is as follows:
Marbat –rf arrayfile [arrayfile2 arrayfile3 ...] –pf positionfile [positionfile2 positionfile3 ...]
[-of outputfilename] [-od] [-ol] [-lf logfilename] [-wt threshold] [-ws] [-ns] [-wfprcap] [-v]
Where items contained in [...] are optional.
Marbat command line options:
-rf

load the given risk parameter file(s)

-pf

load the given position file(s)

-of

name of output file (optional) - default is 'results.{csv|xml}'

-od

output detailed results (optional) - default is to not output

-lf

name of log file (optional) - default is 'mblog.xml'
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-ol

output log file (optional) - default is to not output

-wt

set the warning threshold (optional) - default is 200

-ws

warning stop (optional) - default is to carry on

-ns

use array for Nearest Strike if no array for the actual option strike is available.

-wfprcap

apply capping to WFPR in computation of Method 10 spreads

-v

display version string

Note that it is assumed that anyone using marbat.exe is familiar with the Windows Command line
environment. In the following examples you must substitute “C:\Program Files\.....\marbat.exe”
with the proper/fully qualified path where the marbat executable is located; add this path to the “path”
environment variable; or set default directory to the location etc. You can create a copy of the marbat
executable in an alternative location; simply copy marbat.exe and IceRiskModel.dll to your chosen location.
Basic usage example:
C:\Program Files\.....\marbat.exe ^

–pf My_Positions.csv ^
–rf IPE0909F.csv ^
-wfprcap
The margin results would be written to a file called Results.csv in the default directory. This
example applies WFPR capping as required for Energy margining.
A more complex example:
C:\Program Files\.....\marbat.exe ^

–pf My_Positions.csv ^
–rf LIF0909F.csv OPT0909F ^
–of myResults –od
In this example two array files are specified (LIF0909F and OPT0909F) and the results are written to
myResults.csv. In addition, the –od flag means that the detailed XML output is created and this is written to
myResults.xml. Finally, note that the –wfprcap flag is not specified as this should not be specified for Liffe.
When installed using standard installation settings, marbat.exe will be found in:
•

For 32 Bit Windows platforms:

“C:\Program Files\ICE Clear\ICE Risk Model”; or

•

For 64 Bit Windows Platforms

“C:\Program Files (x86)\ICE Clear\ICE Risk Model”

Notes:
•

The name of the output results files may be changed. For example, to rename the output file the –of
option is used as shown below:
C:\Program Files\.....\marbat.exe -pf data\Position_file.csv –rf
data\Parameter_file.DAT -of Renamed_results.csv

•

A more detailed (xml) file of results will be produced if the –od option is used, for example:
C:\Program Files\.....\marbat.exe -pf data\Position_file.csv -rf
data\Parameter_file.DAT –od

This will produce a file called ‘results.xml’ in addition to the default ‘results.csv’.
•

A log file can be created using the –ol command; for example:
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C:\Program Files....\marbat.exe -pf data\Position_file.csv -rf
data\Parameter_file.DAT –ol

This will produce a file called ‘mblog.xml’.
•

Warnings may be issued such as when the margin calculator is unable to locate the risk data for a
position in a given positions file. The default behaviour will carry on, until 200 warnings have been
generated. However, by using the –wt option it is possible change the setting and force the margin
calculator to stop once it detects a warning – this is achieved by the –ws command.

•

If the positions are in more than one file, use the –pl option, giving the name of a file that itself
contains a list of files. For example:
C:\Program Files\.......\marbat.exe -pl positions.dat -rf data\IF080423.DAT

If the ‘positions.dat’ file contained the following:
abc.csv
def.csv
The margin calculator would load ‘abc.csv’ followed by ‘def.csv’.
The same can be achieved with risk parameter files: the equivalent option if –rl.
•

Finally, it is possible to establish the version of the command line program being used with the –v
option:
C:\Program Files\......\marbat.exe -v
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7

ICE Risk Model Margin Report Details

Summary by Margin Group
This following provides an overall summary of the charges by ICE. For example, for the positions entered in
the position file (see section 4 above) the clearing member would have an initial margin of 1,273 EUR plus
4,300 USD.

Summary by Combined Contract
This gives the summary of all the charges by contract.
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Summary by Scanning Risk
The following gives the final results for each contract, split into the 16 scenarios. It also identifies the
Largest Loss Scenario and the resultant Scanning Risk.
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Summary Value Losses
The following is a breakdown of the Scanning Risk calculation for all futures and options per contract, giving
the results for all 16 scenarios. The results of the delivery month are the summed for each contract. The
options values are summarised from the Option Value Losses report.
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Series Value Losses
The example below is similar to the Summary Value Losses report, but breaks down the losses by each
expiry date.
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Combined Contract Tier Details
The example below shows the Net Delta in each Inter-commodity Tier for each contract.
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Intermonth Spread Charge Details
The document below is a breakdown of the Intermonth Charges for the positions held. For example, the
charge for an intermonth spread with 1 lot long position for December 09 Brent Futures and 1 lot short
position for January 10 Brent Futures.
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Intercontract Spread Credit Details
This report gives the breakdown of any Intercontract Spread Credits you may receive for your portfolio. In
this case, a portfolio with 1 lot long October 09 Brent futures and 1 lot short October 09 WTI futures.
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8

Net Liquidating Value

Note: This section does not apply to OTC FX.
Net liquidating Value (NLV) is calculated by ICE Clear for all premium paid up-front options. It is also
referred to as ‘equity style options’. For these types of option contracts, variation margin is not paid or
received on a daily basis, unlike futures style options. The premium is paid from the buyer to the seller of
the option when the option is first traded. NLV is calculated as follows:
NLV = Market price of option x contract size x number of lots
The concept of NLV allows the clearing house to give members who are long this type of option a credit
that can be used to offset their total initial margin requirement from positions in other contracts. This is
referred to as an NLV credit. In the event of a member default, the clearing house would inherit these long
option positions and it would then, in effect, hold an asset that it could sell (liquidate) and receive the
prevailing market value.
Sellers of premium paid up-front options must fund any NLV debit, as in this situation the clearing house
would be required to close the short position in the event of a default by buying the options back at the
prevailing market price.
Please note that NLV credits and debits are not calculated within the ICE Risk Model margin calculations,
but are credited and debited to member’s margin accounts via the ECS banking system. Therefore NLV
values do not appear in any of the reports shown above.
Clearing members can view NLV credits and debits via the ECS web reporting tool by selecting the ‘MBSR
– Standing Requirements’ report. All reports are available at the following address:
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