# TABLE OF CONTENTS

- REGISTRATION ........................................................................................................... 5
- DEFAULT LAYOUT ........................................................................................................ 6
- WIDGETS, REGIONS, WINDOWS, WORKSPACES .......................................................... 6
- DRAG & DROP / REGION SPLITTING ............................................................................. 7
  - OPEN NEW CONSOLE WINDOW ................................................................................... 8
- REGION MENU CONTROLS ............................................................................................ 8
  - SORT TABS .................................................................................................................. 8
  - TAB POSITION .......................................................................................................... 8
  - ZOOM REGION .......................................................................................................... 8
  - CREATE NEW REGION ............................................................................................... 8
  - MOVE REGION INTO NEW WINDOW ........................................................................... 8
  - REMOVE REGION ..................................................................................................... 8
- QUICK LAUNCH BAR ...................................................................................................... 8
- QUICK LAUNCH BAR SORTING ....................................................................................... 9
- THEMES ......................................................................................................................... 9
- MANAGING WORKSPACES ............................................................................................ 10
- IMPORT DESKTOP VERSION SETTINGS ......................................................................... 10
- MANAGE CONTACTS ................................................................................................... 10
  - ADD CONTACT ........................................................................................................... 11
  - ADD MORE DETAILS TO CONTACT REQUESTS ....................................................... 11
  - ACCEPTING REQUESTS ............................................................................................. 12
  - PRIMARY GROUP ....................................................................................................... 12
    - SET PRIMARY GROUP FOR ENTIRE GROUP ............................................................. 12
  - CONTROL HOW YOU VIEW YOUR CONTACTS ......................................................... 13
  - VIEW CONTACTS’ HANDLES ..................................................................................... 13
  - MY CONTACTS WIDGET (INCLUDING BLOCK USERS) ............................................... 13
- SKYPE PERSONAL SUPPORT ....................................................................................... 14
- EMAIL AS A MEANS TO CHAT ..................................................................................... 16
- IM CAPABILITIES .......................................................................................................... 18
  - PREFERENCES ........................................................................................................... 18
  - TABS SORTING ........................................................................................................... 18
  - CONTACTS SORTING ............................................................................................... 20
  - REGION LABELS ....................................................................................................... 20
    - PRINCIPAL REGION ............................................................................................... 21
    - ADD REGION LABEL ............................................................................................. 21
    - NAMING OF TORN OUT CONSOLES ...................................................................... 22
  - CONTACT LIST .......................................................................................................... 23
    - RIGHT-CLICK MENU - GROUP ............................................................................. 23
    - RIGHT-CLICK MENU - INDIVIDUAL ...................................................................... 24
  - ENHANCED MESSAGE SHORTCUTS ............................................................................ 24
  - MESSAGE SEARCH .................................................................................................... 26
BLASTER

CLEAR BLASTER SELECTIONS AFTER SENDING BLAST MESSAGE ........................................... 26
DISPLAY PRESENCE IN BLASTER ..................................................................................... 27
RECENT ACTIVITY ................................................................................................................. 28

DESK CHAT ............................................................................................................................... 29
MANAGING DESK CONTACTS ............................................................................................... 29
DESK CHAT PREFERENCES ....................................................................................................... 30

DESK ACTIVITY WIDGET ......................................................................................................... 30

CHAT ROOMS .......................................................................................................................... 31
CHAT ROOM EDITOR .................................................................................................................. 32
CHAT ROOM ............................................................................................................................. 33
CHAT ROOM LIST ..................................................................................................................... 34
SPIN OFF CHAT ROOM VIA DRAG AND DROP .................................................................... 34
SPIN OFF CHAT ROOM VIA RIGHT-CLICK .............................................................................. 35
BLAST TO CHAT ROOMS .......................................................................................................... 36

MESSAGE PRIORITIES .............................................................................................................. 36
PUSH NOTIFICATIONS (PNS) FOR CHAT ROOMS AND DESK MESSAGES ...................... 37
EMAIL NOTIFICATIONS FOR MISSED MESSAGES ............................................................... 37
PLAY LOCALLY STORED SOUNDS FOR RECEIVED MESSAGES ...................................... 38
PLAY SOUNDS FOR ACTIVE TAB ............................................................................................. 38
SILENCING ............................................................................................................................... 38
REMINDER ALERTS .................................................................................................................... 38

KEYBOARD SHORTCUTS ......................................................................................................... 39

EMOJIS ....................................................................................................................................... 40

ADDITIONAL TIPS ..................................................................................................................... 40
PREFERENCE TO SEND WITH ENTER KEY ............................................................................. 41
QUICK COPY ............................................................................................................................. 41
DISABLE QUICK COPY ............................................................................................................. 41
COPY ALL MESSAGES .............................................................................................................. 41
QUICK SORTING OF TABS ........................................................................................................ 41
EXPORT CONVERSATION ....................................................................................................... 42
CLEAR MESSAGE HISTORY ..................................................................................................... 42
VIEW MESSAGE LOGS ............................................................................................................ 42
SEND TO MESSAGE CONSOLES IN REGION ..................................................................... 42
BLAST TO ALL OPEN TABS IN REGION .................................................................................. 42
TYING NOTIFICATIONS .......................................................................................................... 42
DISPLAY PRESENCE ICON IN TABS ..................................................................................... 43
CONTACT STATUS IN MESSAGE CONSOLES ......................................................................... 43
CLEARING BADGES FROM NOTIFICATIONS MENU .............................................................. 43
CLEAR ALL BADGES ICON ..................................................................................................... 44
TOASTER PREFERENCES .......................................................................................................... 44
CLOSE ALL OFFLINE TABS ....................................................................................................... 45
CLOSE OTHER TABS ................................................................................................................ 45
DISPLAY SYSTEM MESSAGES IN CHAT ROOMS ................................................................. 45
REMOVE UNDERLINE OF RECOGNIZED MARKETS ............................................................ 45
TEAROUT ON DOUBLE CLICK ............................................................................................... 46
SET DEFAULT WINDOW SIZE ................................................................................................ 46

SMART TEXT RECOGNITION .................................................................................................... 46
DEFAULT PRODUCT FOR CONTACTS

INLINE DISPLAY
- AVAILABLE TOOLS
- PRICING PREFERENCES
- PRICING SOURCE
- LAYOUTS
- LEFT-CLICK PREFERENCE
- DISPLAY BUY AND SELL OPPORTUNITIES
- DECIMAL PLACES FOR ANALYTICS
- MARKET PRICER
- USER INTERACTIONS FOR RECOGNIZED MARKETS
- PRICE SEARCH
- SUBMIT BLOCK
- SUBMIT BLOCK PREFERENCES
- EQUITIES RECOGNITION

REPORT MISRECOGNIZED MARKETS

USER STATUS
- MANAGE STATUS MESSAGES
- ALWAYS AVAILABLE
- AUTO-AWAY TIMER
- MESSAGE FORWARDING

DIRECTORY SEARCH
- YOUR PROFILE
- YOUR CONTACTS’ PROFILES

NOTIFICATION CENTER AND SERVICE MONITOR

GROUPS MANAGER
- GROUPS SORTING

CHROME BROWSER EXTENSION
ICE INSTANT MESSAGING

ICE's enhanced instant messaging (IM) application offers the tools to keep you connected to the people and information that move markets. Featuring an easy-to-use, fully customizable interface, you can tailor your workspace solutions to increase workflow efficiency and react seamlessly to trading opportunities in real-time.

REGISTRATION

There are three ways to launch the new IM service: standalone from www.theice.com, from the WebICE application bar, or in Chrome on your pc or Mac by going to https://iceim.theice.com. Either method will launch the registration process.

Click on the “Let’s get started!” button to begin the account setup process.

If you’ve logged in from WebICE the next screen will allow you to link an existing IM account or have one created for you. If you choose to have one created, an IM account will be auto-provisioned on your behalf and linked to your ICE account.

During the registration you can also link your existing WebICE accounts, as well as your existing AIM and/or Yahoo accounts.

NOTE: if you decide not to do this now you can always link your accounts at a later point in time.
DEFAULT LAYOUT

Once registration is completed, the default layout will be displayed. This layout consists of one main screen containing the Contact List in the left region, a message console in the middle region, and a recent activity in the right region.

WIDGETS, REGIONS, WINDOWS, WORKSPACES

1. **Widget**: A widget is an application. The first widgets available are message tabs, recent activity, contact list, message blaster, groups manager and the directory search.
2. **Region**: A Region is a section within a console window which contains widgets.
3. **Console Window**: A console window can be split into one or more regions, allowing for layout customization.
4. **Workspace**: A workspace is an arrangement of console windows that can be distributed across one or more screens. Users can design and switch between multiple workspaces.

**DRAG & DROP / REGION SPLITTING**

You can open new regions using advanced drag and drop functionality. Drag and drop a group or a contact from the contact list to create a new region and start communicating instantly. Drag a tab from one region to create a new one. As you drag new regions within your workspace, the application will automatically highlight the recommended drop positions and sizes.

There is also the ability to configure your workspace layout prior to opening widgets with the use of region menu options to **Create New Region**.

**On Top / On Bottom**: On Top will open a new region to the top, On Bottom will open a new region to the bottom.

**To Left / To Right**: To Left will open a new region to the left, To Right will open a new region to the right.

**TIP**: When your workspace is just the way you want it, lock it to prevent any unwanted changes.

Easily access other message widgets by clicking on the “+” sign next to the last tab in any region;

- **Blaster**: Send a message to multiple contacts at once
- **Chat Room List**: All of your chat rooms in one widget.
- **Contact List**: All of your contacts in one easy to access list
- **Desk Activity**: Comprehensive view of all desk messages.
- **Directory Search**: Search the ICE directory for contacts and/or desks across multiple markets
- **Groups Manager**: Organize and manage your contact groups
- **Recent Activity**: Comprehensive view of all inbound messages
OPEN NEW CONSOLE WINDOW

You can open a new console window under the File menu.

REGION MENU CONTROLS

To edit the layout, there are controls in the region menus.

SORT TABS
Choose to sort your tabs alphabetically or reverse alphabetically.

TAB POSITION
Change the tab positions to place them on the Top, Left, Bottom, or Right of the region.

ZOOM REGION
Set the zoom view for each region in percent value ranging from 20% to 200%.

CREATE NEW REGION
Open a new region in the current console window. The new region could be opened On Top, On Bottom, To Left, or To Right.

MOVE REGION INTO NEW WINDOW
Tear the region out into its own console window.

REMOVE REGION
Close the region.

QUICK LAUNCH BAR

The quick launch bar is an easy way to launch your widgets. It is available only in the main console and can be displayed/hidden as you desire. Widgets can be launched:

- By left-click: Opens widgets based on preference “When opening a message widget”
- By right-click: Opens widgets in a new window console
- By drag and drop: Place widgets where you desire, including dragging across windows.
If the viewable area the bar is within is too small to display the associated text, only the icons will display with tool tips on hover.

If the viewable area the bar is within gets even smaller, it will display a drop-down for the icons to be displayed.

**QUICK LAUNCH BAR SORTING**

The quick launch bar can be sorted by drag and dropping the buttons to the desired position. There is also the ability to sort them alphabetically or reverse alphabetically by clicking on the gears icon.

**THEMES**

ICE IM offers you the ability to select a theme; currently there are two with more on the way. To select a theme go to Preferences → Themes and select the theme you wish to use.
MANAGING WORKSPACES

We know that you aren’t always working at the same computer every day. Whether you’re your desktop or a laptop, the platform allows you to configure as many workspaces as you require fitting your needs. To switch between different workspaces, click on the Workspaces menu and select the workspace you wish to load.

You can create new workspaces by navigating to Workspaces → Manage Workspaces. From the drop-down select the template you wish to use and click Add. The workspace is now added to your list of workspaces.

The following actions are also available from the Workspace Manager window:
- **Edit workspace name** - click on the pencil next to a workspace name
- **Activate** - changes your workspace view to the selected workspace
- **Clone** - copies the workspace. The cloned workspace can then be edited as needed
- **Remove** - delete the workspace from your account

IMPORT DESKTOP VERSION SETTINGS

Your settings from the desktop version of ICE IM can be exported and subsequently imported into the new ICE IM version.

On the desktop version, go to File → Export → ICE Chat Preferences. Save the file on your pc.

From the new ICE IM, go to File → Import Desktop Version Settings

The following preferences will be imported through this process:
- Default Message Colors: Incoming Message, Incoming Desk Message, and Outgoing Desk Message
- Available Priorities: Priority Keywords, Priority Contacts (individual), Silenced Contacts, and Silenced Phrases
- Message Shortcuts

MANAGE CONTACTS

New contacts can be added from the Add Contact menu and/or the Directory Search. You will have the ability to add an ICE contact as well as someone you know from AIM and/or Yahoo.
ADD CONTACT

From the Contact List, click on the Add Contact icon or navigate to Contacts → Add Contact to send an invite. Simply enter the username and select the service the contact is on.

ADD MORE DETAILS TO CONTACT REQUESTS

When adding a new contact the user will have the ability to add more details to the contact from the Add Contact screen.

Some of the new fields the user will be able to add before even sending the invite are:

- Nickname
- Additional Emails
- Additional Phone
- Default Product
- Notes
ACCEPTING REQUESTS

When you receive a request to become a contact, you will receive a notification through the System Alerts tab. Your pending connection requests will be listed in your contact list under the group Connection Requests. Right-click on a contact within that group to accept, ignore, or block the requestor.

Accept: you agree to become a contact with the requestor who can now contact you via IM. When a new contact is accepted their tab will be automatically opened.

Ignore: you and the requestor are not connected, but the user can always request you as a connection again.

Block: you are blocking the requestor from being able to contact you again. NOTE: you do have the ability to unblock the user at any time.

PRIMARY GROUP

When you add or accept a new contact, you can specify a Primary Group. When you receive a message from a contact whose tab isn’t open, their tab will be opened within their primary group except if your user preference is set to open in Principal Region.

SET PRIMARY GROUP FOR ENTIRE GROUP

Right-click on a group from your Contact List or in the Groups Manager to set the primary group for all contacts within the group.

There is also a button in the Groups Manager, on each group, to perform this function.
CONTROL HOW YOU VIEW YOUR CONTACTS

You can choose to view your contacts by their Full Name or Nickname by going to Contacts ➔ Nicknames.

TIP: If you are viewing by nickname, you will see the nickname they have set for themselves unless you choose to edit.

VIEW CONTACTS’ HANDLES

To view the handles of a contact, go to Edit Contact. The handles are displayed at the bottom of the window.

MY CONTACTS WIDGET (INCLUDING BLOCK USERS)

The My Contacts widget displays all pending requests related to your contacts. Here you can view the connections requests sent, the connection requests received, those contacts who have removed you from their contact list, as well as those users you have blocked.
For each **Sent Connection Request** there is the option to **Cancel Request** or **Block** the user.

For each **Received Connection Request** there is the option to **Accept**, **Ignore**, or **Block** the user.

For each **Blocked User** in the widget there is the option to **UnBlock**.

For each **Removed Contact** in the widget there is the option to **Delete Contact** or **Send Connection Request**.

---

**SKYPE PERSONAL SUPPORT**

ICE IM supports sending and receiving IMs over the Skype personal network. Once enabled, all users are provided their own Skype account - **ICEIMuserid@iceim.theice.com** - which can be used to communicate to users on Skype.

You can view your assigned handle under your profile. Clicking on Upload Contacts will allow you to import your Skype contacts from your account.
When adding a Skype contact only include the username. For example, if you’re looking to add scottbesner@outlook.com only enter scottbesner in the username field. Then select the appropriate domain.

There will be instances wherein the user will accept your connection request in Skype and you will receive an inbound connection request from the Skype server. The request will be in the format cid-(string of numbers)@domain.com (user’s account name). You should accept this contact request and use this to communicate with the Skype contact. You can remove the original contact added.

*** NOTE: For domains which are not listed, there is a different format supported by Skype which is username(domain)@msn.com. For example, if you’re looking to add scottbesner@yahoo.com enter scottbesner(yahoo.com) and then select the domain msn.com from the dropdown. ***

When a connection request is received from a Skype contact it will follow the current workflow.

You will see a request in Incoming Contact Requests group in your Contact List as well as a System Alert indicating a contact request. Simply right-click on the contact request and accept the contact.
Skype contacts can be added on behalf of yourself and/or your desk:

![Skype contacts](image)

Once a connection request is made you can chat with your Skype contacts as you would any of your other contacts.

![Chatting with Skype contacts](image)

**EMAIL AS A MEANS TO CHAT**

You can now be provisioned with an ICE IM email address which enables you to send and receive email messages from your ICE IM client keeping all of your message workflow in one application. All messages in and out of the system run through the ICE IM system, ensuring that our proprietary parsing is applied as well all of your compliance rules. Your email address will be **ICEIMhandle@im.ice**.
When a message arrives from an email address you are not already a contact with, you will have the ability to Accept, Block, or Ignore. The actual message will not be delivered unless you Accept.

**First Message From Non-Contact Email Address**

Once you’re connected to an email address, messages can be sent and received using ICE IM.

When sending a message from ICE IM to an email address the user will see the first line of the message as the subject so they can see what the message is about without even opening it.

**ICE IM Email Tips**
ICE IM does our best to strip out signatures and disclaimers. ICE IM does our best to strip out history so that only the most recent message comes through.

IM CAPABILITIES

Our IM platform offers you not only the basic IM necessities, but also includes some advanced IM features to streamline your workflows.

PREFERENCES

User preferences have been added to control the opening of message widgets.

When a new message arrives ➔ (for your inbound messages)
- **Open New Window Maximazed** = If contact’s tab is open, highlight tab. If contact’s tab is not open - open a new window for their group which pops up.
- **Open New Window Minimized** = If contact’s tab is open, highlight tab. If contact’s tab is not open - open a new window for their group which opens in the background. (Task bar flashes)
- **Open in Principal Region** = If contact’s tab is open, highlight tab. If contact’s tab is not open - open a tab in the region you designated as principal region.
- **Never open New Window** = If contact’s tab is open, highlight tab. If contact’s tab is not open - do not open a new window/tab - just highlight the contact list.

When opening a message widget ➔
- **Open in Same Region** = If contact’s tab is open, focus on the tab. If contact’s tab is not open - open a tab in whichever region you clicked in.
- **Open in Principal Region** = If contact’s tab is open, focus on the tab. If contact’s tab is not open - open a tab in the region you designated as principal region.
- **Open in New Window** = If contact’s tab is open, focus on the tab. If contact’s tab is not open - open a new window for their group which pops up.

TABs SORTING

ICE IM offers the ability to sort tabs under Preferences ➔ Tab Sorting. There are 3 options: Alphabetical, Reverse Alphabetical, or Manual (default).
Tabs will open in their respective regions based on preference selection.

Group By Widget Type Before Sorting: This allows you to specify the order for each widget type, each of which will be opened in the selected order.

Tabs sorted reverse alphabetically:

Same tabs sorted reverse alphabetically with the group by widget selected:
CONTACTS SORTING

You can sort your contacts alphabetically or reverse alphabetically in widgets such as the contact list, the blaster, and the participant lists of your chat rooms. For sorting within the contact list you can also specify if you want to group your contacts by presence before sorting. Go to **Contacts ➔ Contact Sorting Preferences**.

**Contact Sorting Preferences**

Applies to all contact listings (contact list, chat rooms, etc.). Does not apply to tabs.

- Alphabetical
- Reverse Alphabetical

- Group By Presence Before Sorting

Apply & Save  Cancel

REGION LABELS

Regions are tagged with labels indicating which group(s) comprises the region. Regions can contain multiple groups. The opening of message widgets, both manually and upon receiving a message, will abide by the region tags.

When a region is tagged, the labels will be displayed above the tabs:

The task bar as well as the window title bar will display the tags.
If you wish to un-tag a region, hover on the tag and click “x”. This will remove the association between the group and region.

**PRINCIPAL REGION**

You can always set a principal region for opening your message tabs.

Select “Open in Principal Region”, from the following preferences:

- When a new message arrives
- When opening a message widget

With this preference set:

- Manually opening message tabs will open in the principal region if there is no instance of the contact open already
- Incoming messages will open in principal region if there is no instance of the contact open already

You can change the principal region from the Region Menu within any region by selecting “Set as Principal Region”.

In this same Region Menu, you can show or hide region labels by selecting/de-selecting “Show Region Labels”. With this de-selected, the rules of the labels still apply.

**ADD REGION LABEL**
You can add a group label to any region from the Region Menu by selecting “Add Region Label”.

A menu will appear with all of your current groups to choose from.

**NAMING OF TORN OUT CONSOLES**

- When a tab is torn out into a new window console, the window title and task bar icon will display the active tab name.
- When an entire region is torn out, the window title and task bar will display all group labels and widgets as well as the active tab.
- As more widgets, groups, and contacts are added the window title bar will update accordingly.
- With one console the groups and widgets are always displayed as well as each active contact tab in each region.
CONTACT LIST

The contact list widget displays all of your contacts. Contacts are listed within their groups and contacts can be members of more than one group.

Filter Contacts - quickly type-ahead to find the contact you’re looking to message.

The action menu next to the filter contacts box offers you the following capabilities:
- Expand All Groups
- Collapse All Groups
- Show/Hide Offline Contacts
- Show Only Desk Contacts

RIGHT-CLICK MENU - GROUP

The contact list offers functionality via the right-click menu on the group. Users can:
- Open as Group Message Console: if the group is not open elsewhere, this will open the group as a new console window.
- Send a Blast message to the group, seeding the Blaster with members of the group
- Create Chat Room loading the group members into the invite list in the Chat Room Editor. (Permission based)
- Toggle the Visibility of a group within the Contact List and/or Blaster
- Manage Group via the Group Manager
- Delete Group

RIGHT-CLICK MENU - INDIVIDUAL

The contact list offers functionality via the right-click menu on the individual as well. Users can:
- Open in Message Console: will open the contact within a message console, abiding by user preferences.
- Send a Blast message to the user, seeding the Blaster with the selected user
- Create Chat Room loading the contact into the invite list in the Chat Room Editor. (Permission based)
- Edit Contact so you can update their contact details.
- Copy Contact To another group; will place the contact in the selected group as well as keep the contact in the current group
- Move Contact To another group; will place the contact in the selected group and remove them from the current group
- Remove From Group will remove the contact from the selected group
- Disconnect from the contact so they can longer reach you
- Block a current contact from reaching you in the future

ENHANCED MESSAGE SHORTCUTS

Message shortcuts are user defined buttons that allow you to send (or queue up) preset messages. For each button you can configure:

- The button label
- The message associated with the button
- The foreground color of the button
- The background color of the button
- A distribution list to associate with the button (default is none)
To create a message shortcut button, go to Preferences ➔ Message Shortcuts. Click Add New Shortcut. Enter your desired Label for the button as well as the Message to associate. You can configure the Text (foreground) and Background color for the button as well.

If you don’t want to associate any Recipients you can Save this button. If you wish to associate Recipients with the button you can select Chat Rooms, Groups, and/or Contacts.
There are some **General Settings** to set default actions for the left and right clicks. There are 3 options:

- **Auto-Send**: Sends the message to the selected tab if there is no distribution list associated with the button or sends the message to the entire associated distribution list if there is one associated.
- **Insert**: Loads the message into the text entry for the selected tab if there is no distribution list associated with the button or loads the message into the Blaster with the associated distribution list selected.
- **None**: Does nothing on mouse click.

Messages can even be built by pressing multiple shortcut buttons. Message shortcut buttons can be displayed or hidden in each region via the user setting in the region menu.

**MESSAGE SEARCH**

You are able to search through your messages in each region and can elect to search only the current tab or all tabs in the region. Message search can be displayed / hidden in each region via the user setting in the region menu. As you scroll through your results, the text string will be highlighted.

**BLASTER**

Send one message to multiple contacts and quickly pick and choose recipients within the **Blaster**. Each group you create is available to be blasted to.
Sending Messages from the Blaster:

1. Select the group(s) you wish to send message to. This can include Chat Rooms.
2. You may also select/de-select users or chat rooms from the group(s) selected.
   a. There are options for Contact Selection to select None, All, or Toggle between the currently selected and de-selected ones.
3. Type your message in the text entry area and Send.

Type Ahead and Multi-Select

ICE IM offers the ability to quickly search for the contact(s) you wish to select as recipients via type-ahead search. Along with type ahead search you can perform multi-select functions in the blaster to quickly select/de-select recipients.

Blaster Resizing

You can change the layout of the blaster by toggling the groups to be viewable via the icon in the top left.

The divider is now able to be dragged to resize the two regions of the blaster.

CLEAR BLASTER SELECTIONS AFTER Sending BLAST MESSAGE

Select Preferences → Blasting → Clear Blaster Selections After Sending Blast Message to clear out all selected recipients in the Blaster after a message is sent.
DISPLAY PRESENCE IN BLASTER

To view your contacts’ presence in the Blaster go to Preferences → Blasting → Display Presence in Blaster. This will be off by default. If enabled your contacts will display presence in the Blaster.

RECENT ACTIVITY

Recent Activity consolidates and displays all incoming messages in chronological order. Use it as a “ticker” for your IMs and view messages as they are delivered without switching between tabs.
You can quickly respond to an IM from **Recent Activity** by clicking on the contact’s ID. This will open a tab for the contact.

Recent Activity widgets can be filtered by groups and can include/exclude chat room messages.

**DESK CHAT**

Desk chat allows a group / desk of users to chat internally as well as view all external chats between the contacts of the desk. The external recipient only communicates with one shared ID. Unlike a chat room, where each user must “join” a specific chat room and remain there to chat, desk chat propagates the message to each user attached to the desk ID.

**MANAGING DESK CONTACTS**
When a member of a desk adds a new contact they can select to add a contact on behalf of:

- **Individual** – added contact can only be contacted by desk member who added them. Message would come from user’s individual account.

- **Desk** – added contact can be contacted by anyone on the desk. Message comes from desk handle.

When a contact is added as a Desk contact by one member of a desk, the contact is added to all members of the desk as a desk contact. All members of the desk will receive a notification of the accepted connection.

Desk contacts are distinguished with an asterisk (*).

**DESK CHAT PREFERENCES**

When sending a message to a desk contact you can choose whether you wish to display your user name. Under **Preferences → Desk Chat** select **Insert My Username into Messages Sent from Desk Chat** to include your user name.

<table>
<thead>
<tr>
<th>Desk message sent with the preference:</th>
<th>Desk message sent with the preference:</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>On:</strong> Desk123 (userID): this is a desk message</td>
<td><strong>Off:</strong> Desk123: this is a desk message</td>
</tr>
</tbody>
</table>

When another member of your desk sends a message out to a desk contact you will receive a notification. However by default, the tab will not automatically open.

If you wish to have tabs opened when another member of your desk sends a message go to **Preferences → Desk Chat** and select **Open Chat Tabs When Coworkers Send Desk Messages**.

**DESK ACTIVITY WIDGET**

The desk activity widget will display all of your desk messages in one tab. This tab includes all inbound and outbound messages for your desk.

Sending messages in this widget will *only* send messages to your desk, *never* externally, just like your internal desk chat. This allows a desk to get a full picture of the markets they’re working with their customers while interacting with their own, internal desk.
Although all external messages are displayed here, they are not seen by other external contacts. When an external contact needs to be contacted, clicking on their user name in the window will bring you directly to their tab.

The widget can be filtered to view the messages you wish to see and you can open multiple instances of the widget with different filters set.

Message types within the desk activity widget are:

1. Message sent by your to your internal desk.
2. Message sent by someone on your desk to your internal desk.
3. Message sent by anyone on your desk to an external desk contact, including blast messages to desk contacts.
4. Message received from any external desk contact.

CHAT ROOMS

Chat rooms, which can be created on the ICE server, AIM, and/or Yahoo, are fully compliant and controlled by each user’s permissions. Users can be permissioned for the following access on chat rooms:

- **Restricted**: Access to chat rooms has been revoked
- **Company Only**: User can only participate in chat rooms with users from their company
- **Company +1**: User can participate in chat rooms with users from their company and one other company only
- **Full Access**: User can participate in chat rooms with any users
NOTE: AIM and Yahoo chat rooms are enabled or disabled only

Once you’ve received permissioned access, be able to access your running chat rooms from your Contact List and/ or the Chat Room List. Snapshots will only be available in the Chat Room List.

CHAT ROOM EDITOR

If the service type is ICE, you can:

Determine whether members are able to view message history when they join by selecting or deselecting "Reload entire chat room history when a new member joins"; this is selected by default.

You can make the room permanent or temporary by selecting or deselecting "Keep this chat room running until I delete it"; this is selected by default.

You can name the room and select the service you want to create the room on. Inviting contacts is made easy via filtering by company, group, and/or type-ahead search.

You can create snapshot templates of chat rooms for quick start up of a new room.
CHAT ROOM

All users will receive announcements when another user has joined or left.

Action buttons:

- **Edit** the room - add/remove participants
- **Leave** the room - you will receive no messages sent in the chat room but can rejoin at your convenience
- **Remove** the room - you will need to be re-invited to the chat room in order to participate. Room is removed from your platform.
- **Delete** the room (creator only) - chat room is deleted from the server for ALL participants.

You’re able to:

- Invite other users
- Remove other users
- Filter messages

All users must accept invite.

All active chat rooms will appear in your contact list as well as the Chat Room List.

Chat Room Resize

You can now choose to hide the side panel of a chat room or resize. To resize the side panel simply drag the divider to the desired size.

To show/hide the side panel there is a toggle in the top left corner of each chat room.
CHAT ROOM LIST

Under Running Chat Rooms you will find a list of all the chat rooms you are currently a participant of; including information on the number of unread messages and the number of participants. All action buttons listed above are available in this widget as well.

There is also a list of your Saved Chat Room Snapshots, which allow you to spin up a chat room from a template.

SPIN OFF CHAT ROOM VIA DRAG AND DROP

You can quickly spin up a chat room and add contacts to a chat room via drag and drop. While on the tab you want to spin off the chat room with, drag any other contact into the middle of the region to see target drop points. Simply release the contact onto Create Chat Room to start up a chat room with the two contacts and you!

To add other contact(s) to any existing chat room, drag them into the middle of the chat room region and drop them on Add To Chat Room.
SPIN OFF CHAT ROOM VIA RIGHT-CLICK

Clicking on a chat tab now offers the ability to invite more users to a chat room by selecting **Invite More Contacts**. This selection will bring you to the **Chat Room Editor** widget with the current contact selected.

From here you can select other contact(s) to invite to a chat room. Message history will not be carried over so new people joining will not see what was discussed previously.
BLAST TO CHAT ROOMS

Chat rooms can be selected as recipients of your blast messages. You can select which chat rooms to send a blast message to within the blaster or you can include them when blasting from a region.

If your Chat Rooms group isn’t visible in the Blaster, right-click on the Chat Room group and select **Visibility → Blaster**.

Under **Preferences → Blasting** select **When sending a blast from a region include chat rooms to include chat rooms when blasting from a region menu or from the arrow next to Send**.

Select **Open chat room tabs when I include them in a blast** if you want the chat room to open when included in your blast.

MESSAGE PRIORITIES

With priority messaging you can play a custom sound and display a custom color tab every time a message is received from a specified contact or whenever a message contains a specified keyword. You can also indicate when you want a push notification sent to your phone.

You can set message priorities under the Notifications menu. Your default message priorities can be found by navigating to **Notifications → Message Defaults**. Here you can view or edit the default notification settings for messages received.

Under **Notifications → Priorities** you have the ability to:

- View **Available Priorities** as well as create more of your own
- View predefined **Prioritized Keywords** and add your own keywords
• Define Prioritized Contacts

PUSH NOTIFICATIONS (PNS) FOR CHAT ROOMS AND DESK MESSAGES

Under Notifications → Message Defaults a user is now able to select to send push notifications for missed messages in a chat room as well as for inbound and outbound desk messages. For chat rooms, the PNS will be sent based on your status, whether you’re away or offline, as well as if you’re a member of the chat room.

For desk messages, the PNS will be sent based on your status, whether you’re away or offline regardless of anyone else on the desk being available. This means that although a contact of the desk might see the desk as available, you can still receive PNS for those messages.

<table>
<thead>
<tr>
<th>Default Message Colors and Sounds</th>
</tr>
</thead>
<tbody>
<tr>
<td>Type</td>
</tr>
<tr>
<td>----------------------------------</td>
</tr>
<tr>
<td>Incoming Message</td>
</tr>
<tr>
<td>Incoming Desk Message</td>
</tr>
<tr>
<td>Outgoing Desk Message</td>
</tr>
<tr>
<td>ICE Chat Rooms</td>
</tr>
</tbody>
</table>

EMAIL NOTIFICATIONS FOR MISSED MESSAGES

Similar to getting push notifications (PNS) for missed messages sent to your phone, you will now be able to have an email sent for your missed messages. This can be set from Notifications → Message Defaults. A new column, Send Email Notifications When I’m is available with the following choices:
• Away of Offline - sends an email
• Away
• Offline
• Never

The email will be sent to the email you are registered for ICE IM under. These emails for missed messages are batched on the server and delivered so as to not inundate you with emails.

The email will come from ICE IM with the message in the email.
PLAY LOCALLY STORED SOUNDS FOR RECEIVED MESSAGES

You are able to select your own sounds for your incoming messages by going to the priority you wish to update and clicking the sounds file icon. This will allow you to browse your computer for your own .wav files to play when a message is received.

<table>
<thead>
<tr>
<th>Default Message Colors and Sounds</th>
</tr>
</thead>
<tbody>
<tr>
<td>Type</td>
</tr>
<tr>
<td>---------------------</td>
</tr>
<tr>
<td>Incoming Message</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Priorities</th>
</tr>
</thead>
<tbody>
<tr>
<td>Priority</td>
</tr>
<tr>
<td>-----------</td>
</tr>
<tr>
<td>1</td>
</tr>
</tbody>
</table>

PLAY SOUNDS FOR ACTIVE TAB

Under Notifications → Sounds you can select to Play Sounds For Active Tab. With this selected, your sounds will play for the active tab.

SILENCING

Contacts, entire groups, or specified phrases can be silenced within the platform. When silenced, the message is still received but no notification is displayed to the user. Silencing settings are found under Notifications → Silencing.

REMINDER ALERTS

For each priority there is the ability to set a reminder alert so if a message tab has not been acknowledged, a new alert can be triggered. This is available for the Message Defaults and Available Priorities, both of which are found under the Notifications menu.
For each priority, the reminder alerts can be set under the Remind Me column. The default is set to Never, which means no reminder will be triggered. To enable a reminder, change Never to After and select the time period after which a new alert will be sent.

### Priorities

<table>
<thead>
<tr>
<th>Priority</th>
<th>Color</th>
<th>Sound</th>
<th>Send Mobile Push Notifications</th>
<th>Remind Me</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>Red</td>
<td>Default</td>
<td>Always</td>
<td>After 1 minutes and 0 seconds</td>
</tr>
<tr>
<td>2</td>
<td>Yellow</td>
<td>Default</td>
<td>Always</td>
<td>Never</td>
</tr>
<tr>
<td>3</td>
<td>Green</td>
<td>Default</td>
<td>Always</td>
<td>Never</td>
</tr>
</tbody>
</table>

The alert will make the tab flash/pulse from a bright shade of the associated color as well as make the task bar flash.

### KEYBOARD SHORTCUTS

ICE IM is shipped with 2 keyboard shortcuts allowing you to quickly navigate through your open tabs in a region. Keyboard shortcuts can be found under Preferences → Manage Keyboard Shortcuts.
EMOJIS

ICE IM offers a set of emojis which contains search capabilities.

Emojis can be inserted by clicking on the emoji symbol next to the send button.

To search for an emoji, enter your term in the search box within the emoji selector.

ADDITIONAL TIPS

The IM platform has built in user shortcuts to improve your workflow.
PREFERENCE TO SEND WITH ENTER KEY

The default in ICE IM is to send a message when the enter key is struck. There is a preference to change this: Preferences ➔ Send Message with Enter Key.

QUICK COPY

Copy and paste content from messages by clicking and dragging over the text. You can quick copy by clicking to the left of the text; this copies the text of the message excluding the timestamp and userID.

The following text will be copied: “wti z 50 calls”

DISABLE QUICK COPY

Quick copy can be disabled/enabled under Preferences. There is a selection to Disable Quick Copy.

COPY ALL MESSAGES

You can right-click in the body of a tab and select Copy All Messages to copy the entire message within the tab, including the timestamp and userID(s).

QUICK SORTING OF TABS

This is only available while you’re in manual sort mode. Quickly sort your tabs in each region on the fly with a menu choice in the Region menu. Click on the Region menu and select Sort Tabs. You can then select to sort them alphabetically (A-Z) or reverse-alphabetically (Z-A).
EXPORT CONVERSATION

To export the conversation from the selected tab into a .txt file, right-click and select Export Conversation.

CLEAR MESSAGE HISTORY

To clear out message history within a tab, you can right-click on the tab and select Clear Message History.

VIEW MESSAGE LOGS

Need to see more history? Right-click on the contact’s tab and select View Message Logs. This will load up the client area as a tab in a new window console with the logs between you and the contact selected.

NOTE: viewing logs is contingent upon your company’s compliance recording preferences.

SEND TO MESSAGE CONSOLES IN REGION

Quickly send a blast message to all contacts tabs open in a region by clicking the arrow next to Send and clicking Send to Message Consoles in Region. The message is sent to all open message console tabs within the region upon clicking.

BLAST TO ALL OPEN TABS IN REGION

By clicking Send Blast under the Region Menu, the Blaster will be seeded with all contacts for whom a tab is opened in the region.

TYPING NOTIFICATIONS

While you’re on a tab, you are able to view whether or not your contacts are responding to you. If they are actively typing a message to you, their name in their tab will be underlined. In addition to the underline of the tabs who are currently typing, you will see “is typing” in the active message console.

Sending and receiving these notifications can be controlled by going to Contacts → Typing Notifications and toggle:
- **Display Typing Indicators in Message Tabs** - controls seeing whether your contacts are actively typing to you
- **Send Typing Notifications** - controls whether you want your contacts to see that you are actively typing to them.

**DISPLAY PRESENCE ICON IN TABS**

You can choose to view your contacts' presence icon on the chat tabs themselves to quickly see if a contact is available, away, or offline.

To enable this preference, go to Preferences menu and select **Display Presence Icons in Chat Tabs**

![Preferences Menu]

**CONTACT STATUS IN MESSAGE CONSOLES**

You can view your contacts’ status message in the message console as well as the Contact List.

![Contact Status]

**CLEARING BADGES FROM NOTIFICATIONS MENU**

You can quickly clear badges across the entire platform or for each region. To clear badges across the entire platform navigate to **Notifications → Clear All Badges**.
To clear badges for a specific region, click on the Region Menu and select:

- **Clear All Badges** - clears all badges within the selected region
- **Clear Outgoing Badges** - clears all outbound (desk) badges within the selected region

**CLEAR ALL BADGES ICON**

You can quickly clear badges across the entire platform by simply clicking on the **Clear All Badges** icon found to the right of the **Help** menu.

**TOASTER PREFERENCES**

Toaster preferences can be found under **Notifications ➔ Toasters**.

**Show Toasters On:** There are four choices of where to display the toasters:

- Top Left
- Top Right
- Bottom Left
- Bottom Right (default)

The toasters will display in the location the user selected on the monitor where their “main” window displays.

**Show Toasters for All Incoming Messages:** This will control seeing the toaster pop-up for all inbound messages, including desk messages.

**Show Toasters for Outbound Desk Messages:** This will control seeing the toaster pop-up for all outbound desk messages.

**Show Toasters for Chat Rooms:** This will control seeing the toaster pop-up for all chat room messages.
CLOSE ALL OFFLINE TABS

When you wish to "clean up" your message console and remove those users who are no longer online, click on the Region Menu and select Close All Offline Tabs.

CLOSE OTHER TABS

While on a tab, right-click and select Close Other Tabs to close all tabs except the one you’re actively on.

DISPLAY SYSTEM MESSAGES IN CHAT ROOMS

A toggle has been added via right-click to allow a user to display or hide the system messages in chat rooms. Right-click anywhere in the message history of a chat room to select / deselect Display System Messages.

REMOVE UNDERLINE OF RECOGNIZED MARKETS

A preference is added to change the display of recognized markets from the blue, underlined text to the same as “regular” text. The recognized markets will retain all their functionality.
Go to Preferences → Underline Recognized Markets to toggle this off and on.
TEAROUT ON DOUBLE CLICK

A new preference is added to control tearing out a tab when double clicking. This preference is found under **Preferences → Open Tabs in New Console on Double Click**. This will be selected by default which tears a tab out into its own window when double clicked. Deselecting the preference will disable this.

SET DEFAULT WINDOW SIZE

When you resize a window, the size will be saved and automatically set as the default size for all new windows opened.

SMART TEXT RECOGNITION

ICE IM offers proprietary message recognition technology which turns market messages into market data. Connect an analytics model to ICE IM and get instant feedback on buy/sell opportunities.

ICE IM allows the customization of the message data views; Display the data you want wherever you want.

DEFAULT PRODUCT FOR CONTACTS

To properly utilize our proprietary recognition engine, ensure your contacts are set with the proper default products. If one is not set properly, you must specify the product you’re sending a market on. You can set a contact’s default product by editing the contact.

INLINE DISPLAY

Once enabled for recognition, the message views can be set to display analytics and pricing in the message layouts themselves. The following pieces of data will be available as tools, all of which can be added or removed in the message layouts as desired. The data tools can be added in any order via drag and drop functionality.

AVAILABLE TOOLS

<table>
<thead>
<tr>
<th>Name</th>
<th>TOOL DISPLAY</th>
</tr>
</thead>
</table>

INTERCONTINENTAL EXCHANGE | ICE Instant Messaging | April 2018 | 46/69 |
PRICING PREFERENCES

All ICE IM users can send and receive markets to and from their counterparties. However, to take advantage of the added recognition functionality special permissions are required.

Once permissioned a new menu option, Pricing, will be available under Preferences.

PRICING SOURCE

There are two selections to get pricing in ICE IM:
1. **Trade (Application):** sends the analytics and pricing values through from the Trade application. These values will come through whether the pricing api or Options Analytics is being used in Trade.
2. **Options Analytics (Server):** uses the valuations from ICE Options Analytics

LAYOUTS

ICE IM offers full customization of the message layouts once permissioned for recognition. Four predefined layouts are provided. Note that the only portion of the message layout which cannot be broken up is the timestamp, sender, and message.
**BASIC DOCKED**

- This layout does not change the current layout of the messages.
- There is no inline data and all analytics and pricing is displayed in the market pricer at the bottom of the consoles.

**DOCKED**

- This layout adds a theo indicator to the left of the message timestamp as well as an ICE indicator when there is a better price on ICE for the same market.
- All analytics and pricing is displayed in the market pricer at the bottom of the consoles.

**BASIC**

- This layout adds a theo indicator to the left of the message timestamp as well as an ICE indicator when there is a better price on ICE for the same market.
- A new line break and a tab space are added after the message, creating a new line for the analytics data.
- On the new line will be a colored theo price and the delta.

**ALL TOOLS**

- The All Tools layout will add all available tools to the message layout.
- To the left of the message timestamp will be a theo indicator as well as an ICE indicator when there is a better price on ICE for the same market.
- A new line break and a tab space are added after the message, creating a new line for the analytics data.
- On the new line will be all of the available tools.
CUSTOMIZE LAYOUTS

The predefined layouts can be customized as desired by simply dragging and dropping tools into and out of the layout as well as reordering.

All changes are updated and saved dynamically for the layouts.

CREATE NEW LAYOUTS

Clicking the "+" button on the Layouts layer provides the ability to create a new blank layout or add any Preset layouts. Likewise, the ability to duplicate the selected layout will be available.

COPY LAYOUTS
By selecting a layout and then clicking on the drop-down arrow, an option to **Copy Layout** is presented. Clicking this will copy the layout. From there, the layout can be customized.

**DELETE LAYOUTS**

Select the layout to delete and click the Delete button.

**LEFT-CLICK PREFERENCE**

For all layouts, there is a preference for the left-click action on a recognized market. **When I left-click on a Recognized Market,**

- **Display Market Pricer** - opens the market pricer in the bottom of the consoles
- **Open in Watch Tab** - selects the market in the Market Watch in **Trade**.

**DISPLAY BUY AND SELL OPPORTUNITIES**

The colors displayed for buy and sell opportunities can be configured as well. This will be under “**Display Preferences when comparing Theo vs Bid/Offer**”.

These colors will affect the **Theo Indicator** tool as well as the **Theo with Color** tool.

- Select the base color for **Sell** and **Buy** opportunities from the respective sliders. The default base colors are red for a sell opportunity and green for a buy opportunity.
- Select the number of ticks to shade the **Theo Indicator** and **Theo with Color** tools by. The default number of ticks is 3.
- Once the selections are made, a preview of the various shadings will be displayed in the color sliders.

Default settings for the preferences:
Customized settings for the preferences:

**THEO INDICATOR**

The Theo Indicator tool will display as a colored circle displaying when there is a buy/sell opportunity, based on the preference settings, when there are prices sent/received on the IM markets. Should there be no buy/sell opportunity the neutral indicator is a gray circle.
If no prices are included on the IM markets or a market was reloaded the Theo Indicator tool will display as a dash, clearly indicating there was no price to check against the model.

DECIMAL PLACES FOR ANALYTICS

If the Pricing Source is set to Trade (Application) the decimal places will be displayed as they are set within the Trade application.

If the Pricing Source is set to Options Analytics (Server) there is a slider to select how many decimal places to display the analytics.

MARKET PRICER

The market pricer is available on the bottom of the consoles and can be displayed based upon the left-click preference being set to Display Market Pricer or by adding the Open Pricer tool into any views and clicking that.

The layout of the market pricer is not customizable and contains the following information.

In the top left of the market pricer will be the ICE IM standardized string for the recognized market. This will show confirmation of what was actually recognized and constructed by the ICE IM recognition engine.

In the top right of the market pricer will be the timestamp of the message along with a Reprice tool, an action menu, and ability to close the pricer itself.

BQty, B, O, and OQty: These four fields represent the ICE screen prices for the same market if available. The Bid and Offer fields will have the Open ICE Order Ticket tool to quickly allow for order entry on the Trade application.

Theo with Color tool will display the theo returned from the pricing source colored if a potential buy or sell opportunity is there based on the preferences.

Delta [Residual Delta], Gamma, Vega, Theta are all returned from the pricing model.

Clicking on the Reprice tool will update the analytics data for the market loaded in the pricer. The timestamp will update with the time the new pricing data was received.

The action menu contains the action items available for the market in the pricer, much like the right-click menu on a recognized string. These actions are documented in the User Interactions section.
USER INTERACTIONS FOR RECOGNIZED MARKETS

The actions available for recognized markets are based on permissions and user preferences.

THEO INDICATOR - PIN MARKET

Clicking on the Theo Indicator tool will pin a market to the Market Watch tab in the Trade application. The theo indicator tool itself will change to a pin icon indicating that the market was successfully pinned to the market watch tab.

OPEN ICE ORDER TICKET

If a market received and recognized has a corresponding market listed on the ICE, clicking this tool will open an order ticket in the Trade application.

OPEN PRICER

Use the Open Pricer tool to view the docked market pricer on the bottom of the console for more information.
**REPRICE**

Click the **Reprice** tool to refresh the analytics for the market.

**LEFT-CLICK**

On the preferences screen there is a setting for the left-click action. When I left-click on a Recognized Market, has two choices available:

- **Open in Watch Tab** - brings the market into focus in the Market Watch tab in Trade.
- **Display Market Pricer** - opens the Market Pricer in the bottom of the ICE IM console.

**RIGHT-CLICK**

The right-click menu will be available on all recognized markets. Available options are dependent upon user permissions.

- **Submit RFQ** prepopulates the RFQ Wizard in Trade. **
• Submit Cross prepopulates a crossing order ticket in Trade. **

• Submit Block prepopulates a block order ticket in Trade. **

• IM Blast prepopulates the ICE IM Blaster with the recognized market string.
- **Copy** copies the market string.
- **Open in Watch Tab** brings focus to the market in the market watch tab
- **Pin Market** pins market to the top of the market watch tab

**Reprice Market** reprices the market’s analytics.

**Requires an ICE account with permissions to Trade and/or Block.**

**ACTION MENU IN MARKET PRICER**

The action menu found in the market pricer will have the same menu options as the right-click menu described above.
PRICE SEARCH

The Price Search functionality provides the ability to price markets prior to sending. The price search is available in the blaster by default and can be added to the message consoles and desk activity widget if desired. It can be toggled off/on in any of these widgets from any of the region menus.

PRICE A MARKET

- Type a market into the field Find market to price...
- Price the market by:
  - Clicking the Price button
  - Hitting the Enter key
  - Hitting F9
• Click **Insert** to populate the market into the text entry area and **Send** when ready.

**REPRICE AND RESEND MARKETS**

The price search text entry field is also a type-ahead drop-down displaying the last ten recognized markets priced and/or sent.

Select a previous market to price again to get an updated snapshot of the analytics.

**SUBMIT BLOCK**

If you are permissioned for block trading on ICE, when a recognized market is received you can have the ICE Block order ticket automatically populated with the order details by right-clicking on the recognized market and selecting **Submit Block**.

The ticket will open in WebICE or ICE Block for you to submit for straight-through-processing on the ICE trading platform.
SUBMIT BLOCK PREFERENCES

Once a block ticket is submitted, pre- confirms and confirms are automatically sent via IM on behalf of your desk. If you wish to modify these settings go to Preferences → ICE Block.

- Auto Send Pre-confirm and Confirm Messages
- Send Confirm Messages on Behalf of Desk

EQUITIES RECOGNITION

Inline Analytics also supports displaying the analytics data for recognized equities data via the ICE IM API (AppLink).
Users may now report a misrecognized IM quote to the ICE Market Recognition team directly from their message console.

To report a misrecognized market, right click on the market and select Report Misrecognized Market OR Right click next to a completely unrecognized market and select Report Misrecognized Market.

In the Report Misrecognized Market dialog box, enter the Expected market and any comments on how it should be properly parsed, then click submit. The recognition team will receive your report and follow up if they have any questions regarding the submission.
USER STATUS

There are 3 user statuses available on the IM platform. A user can set their status to:
- **Available**: your contacts see you online and active
- **Away**: your contacts see you online and inactive
- **Invisible**: your contacts do NOT see you online

You can change your status by clicking on the menu under your profile in the top right corner of your main console window. You can also associate a status message to be displayed to your contacts.

MANAGE STATUS MESSAGES

Under the status sub-menu, is Manage Status Messages. Here you can create custom messages to associate with your status; Once created they will appear in the menu above.

ALWAYS AVAILABLE

You can manage your settings to never appear “away” or “offline” to your contacts by clicking on your name in the top right corner of the main window. Simply hover over the Available or Away menu to open the sub-menu and select Manage Availability & Auto-Away. In the window will be a setting While I’m away of offline:

To always show available to your contacts select **Appear available to contacts and receive PNS based on priority**.
**AUTO-AWAY TIMER**

The platform will automatically set your status to away based on your specified settings. You can adjust this setting under the status sub-menu by selecting *Manage Availability & Auto-Away*.

**TIP:** If you wish to *NEVER* appear away, enter 0 minutes.

**MESSAGE FORWARDING**

*Message Forwarding* allows you to forward your message to another contact on ICE IM when you’re online and away, or offline.

To set up message forwarding, open the *Message Forwarding Setup* window and select a contact to be the recipient of your forwarded messages.

- To turn on message forwarding while you’re online but away, select *Enable online message forwarding*
- To turn on message forwarding while you’re offline, select *Enable offline message forwarding*
- You can decide if you want to receive a mobile notification for each message which gets forwarded on your behalf by selecting the checkbox *Send mobile notifications when enabled*
- Each forwarded message can display which IM service the original sender was on if you so choose, just select *Show IM service in forwarded messages*

A user who forwards a message will see that message both in the chat window for the original sender and also copied into the chat window of the forwarding recipient.

A user who is the recipient of a forwarded message will receive the message on the tab of the forwarding user. In order to reply to the original sender of the message, the forwarding recipient and original sender must be connected. The actual sender will be *hyperlinked* in the forwarded message to allow the forwarding recipient to quickly reply or add the original sender as a contact if they are not connected.
DIRECTORY SEARCH

The Directory Search provides access to a community of more than 20,000 ICE participants via a digital rolodex containing user profiles customized to meet the privacy requirements of each firm and/or user.

You are able to search for individual contacts as well as desks. All searches on individual contacts outside your own firm must include at least two of the following: first name, last name, nickname and/or company. If you’re searching for a desk, these rules do not apply.

YOUR PROFILE
You can upload a profile picture, edit your nickname, and add the contact information you want to make available to your contacts. Simply click Edit Profile under your name in the top right corner of the main window.

When you edit your own nickname, this becomes the nickname all of your contacts will view (based on their preferences) unless they've added their own nickname for you.

Clicking on the Chat Accounts tab will display all of your linked accounts.

If you did not link your AOL or Yahoo account during registration, you can do it here by clicking on Link Account.

Even after you linked your Yahoo account, you have the ability to update the contacts by clicking on Upload Contacts.
YOUR CONTACTS’ PROFILES

You can view your contacts’ information by right-clicking on them from a tab or from the Contact List and selecting Edit Contact.

Here you’ll be able to view the basic contact information.

Click the Edit button to enable editing of their contact information. This includes editing their Primary Group, Priority, and Default Product for recognition.

NOTIFICATION CENTER AND SERVICE MONITOR

The Notification Center and Service Monitor are available to give you more insight into what is going on with your account. The Notification Center will provide ICE the ability to notify users of information related to their account while the Service Monitor gives you a view of your accounts connectivity and services.

Both can be found in the upper right corner of your main console under one new icon: 📣. The icon will display in the color of the highest priority of any items under it when there is a reason to notify you.

Under Service Monitor you will be able to see the connectivity of the following, provided they’re permissioned:

- ICE IM
- AIM
- Skype
- ICE Connect
- Desktop Controller
- Analytics
- Chrome Extension - only available in Chrome
Notifications will come into the Notification Center only when sent from ICE. ICE will decide whether the message could be cleared by the user or not. If so, there will be an “x” to clear it, if not the notification can only be cleared by ICE.

GROUPS MANAGER

The Groups Manager provides an interface to make mass updates to your groups.

In the first view of groups manager you can view all of your groups with some basic information about them. The group order can be rearranged here via drag and drop.
Clicking on any group will open a more detailed group view where you are able to:

- Edit group name - simply type the new name in the Name field
- Edit membership of groups
- Delete Group
- Control a group’s visibility - choose to have the group Visible in Blaster and/or Visible in Contact List

**QUICK TIP:** Utilize the various type-ahead filters to quickly find contact(s) to take action on:
- Contact
- Company
- Group

**GROUPS SORTING**

On the main page of the Groups Manager, to the right of the Add New Group link is a toggle to quickly sort your groups A-Z, Z-A, or manually.
CHROME BROWSER EXTENSION

The ICE Instant Message Chrome extension provides users some of the functionality of the full Instant Message application inside Chrome such as:

- Taskbar Notifications/Flashing
- Quick Copy Functionalities
- Status Reports (Available vs. Away)

To install the Chrome Browser Extension, go to the Service Monitor when you’re running in Chrome. You will see ICE IM Chrome Extension with an Install button. Simply click the Install and follow the prompts.

Open Service Monitor and Click Install

Click Add on the Confirm Screen
Once the install is done you will see a Restart button in the Service Monitor, click this to complete the installation.

SUBMIT FEEDBACK
If you would like to submit feedback go to Help → Submit Feedback; we are always looking to improve our platform, and would welcome your comments and feedback.