Click here to download and run the installer (4.7.2 Build) following the on-screen instructions.

System requirements to run ICE XL as follows:

  • Microsoft Windows Vista, 7, 8 or 10
  • Microsoft Excel 2007, 2010, 2013, 2016, and 365 (32-bit and 64-bit)